MPI

From Research Computing Center Wiki
Jump to: navigation, search



MPI Libraries for parallel jobs on Sapelo2

All compute nodes on Sapelo2 have Infiniband (IB) interconnect. Various IB-enabled MPI libraries are available and users can set the environment variables for the MPI library of choice by loading the corresponding module file. For more information on Environment Modules, please see the Lmod page.

The following MPI libraries are available:

MVAPICH2

You can find all MVAPICH2 modules available on Sapelo2 by running the following command on a Sapelo2 node:

module spider mvapich2

These are some of the modules available:

  • MVAPICH2 2.2, using GNU 5.4.0 compilers, available in module MVAPICH2/2.2-GCC-5.4.0-2.26. To use it, load the module with
module load MVAPICH2/2.2-GCC-5.4.0-2.26
  • MVAPICH2 2.2, using GNU 6.4.0 compilers, available in module MVAPICH2/2.2-GCC-6.4.0-2.28. To use it, load the module with
module load MVAPICH2/2.2-GCC-6.4.0-2.28
  • MVAPICH2 2.2, Intel 2013_sp1.0.080 compilers, available in module MVAPICH2/2.2-iccifort-2013_sp1.0.080. To use it, load the module with
module load MVAPICH2/2.2-iccifort-2013_sp1.0.080
  • MVAPICH2 2.2, Intel 2015.2.164 compilers, available in module MVAPICH2/2.2-iccifort-2015.2.164-GCC-4.8.5. To use it, load the module with
module load MVAPICH2/2.2-iccifort-2015.2.164-GCC-4.8.5
  • MVAPICH2 2.2, Intel 2018.1.163 compilers, available in module MVAPICH2/2.2-iccifort-2018.1.163-GCC-6.4.0-2.28. To use it, load the module with
module load MVAPICH2/2.2-iccifort-2018.1.163-GCC-6.4.0-2.28

Once the appropriate module is loaded, you can compile code with mpicc, mpic++, mpif90, etc and you can run applications that were linked to the MPI libraries loaded by the module.

OpenMPI

You can find all OpenMPI modules available on Sapelo2 by running the following command on a Sapelo2 node:

module spider openmpi

These are some of the modules available:

  • OpenMPI 3.0.0, using GNU 7.2.0 compilers, available in module OpenMPI/3.0.0-GCC-7.2.0-2.29. To use it, load the module with
module load OpenMPI/3.0.0-GCC-7.2.0-2.29
  • OpenMPI 2.1.2, using GNU 6.4.0 compilers, available in module OpenMPI/2.1.2-GCC-6.4.0-2.28. To use it, load the module with
module load OpenMPI/2.1.2-GCC-6.4.0-2.28
  • OpenMPI 1.10.3, using GNU 5.4.0 compilers, available in module OpenMPI/1.10.3-GCC-5.4.0-2.26. To use it, load the module with
module load OpenMPI/1.10.3-GCC-5.4.0-2.26
  • OpenMPI 1.10.3, using GNU 4.4.7 compilers, available in module OpenMPI/1.10.3-GCC-4.4.7. To use it, load the module with
module load OpenMPI/1.10.3-GCC-4.4.7
  • OpenMPI 3.0.0, using Intel 2018.1.163 compilers, available in module OpenMPI/3.0.0-iccifort-2018.1.163-GCC-6.4.0-2.28. To use it, load the module with
module load OpenMPI/3.0.0-iccifort-2018.1.163-GCC-6.4.0-2.28
  • OpenMPI 2.1.2, using Intel 2018.1.163 compilers, available in module OpenMPI/2.1.2-iccifort-2018.1.163-GCC-6.4.0-2.28. To use it, load the module with
module load OpenMPI/2.1.2-iccifort-2018.1.163-GCC-6.4.0-2.28
  • OpenMPI 1.10.7, using Intel 2018.1.163 compilers, available in module OpenMPI/1.10.7-iccifort-2018.1.163-GCC-6.4.0-2.28. To use it, load the module with
module load OpenMPI/1.10.7-iccifort-2018.1.163-GCC-6.4.0-2.28
  • OpenMPI 1.10.7, using Intel 2015.2.164 compilers, available in module OpenMPI/1.10.7-iccifort-2015.2.164-GCC-4.8.5. To use it, load the module with
module load OpenMPI/1.10.7-iccifort-2015.2.164-GCC-4.8.5
  • OpenMPI 1.8.4, using Intel 2015.2.164 compilers, available in module OpenMPI/1.8.4-iccifort-2015.2.164-GCC-4.8.5. To use it, load the module with
module load OpenMPI/1.8.4-iccifort-2015.2.164-GCC-4.8.5
  • OpenMPI 1.8.4, using Intel 2013_sp1.0.080 compilers, available in module OpenMPI/1.8.4-iccifort-2013_sp1.0.080. To use it, load the module with
module load OpenMPI/1.8.4-iccifort-2013_sp1.0.080

Once the appropriate module is loaded, you can compile code with mpicc, mpic++, mpif90, etc and you can run applications that were linked to the MPI libraries loaded by the module.


Back to Top


MPI Libraries for parallel jobs on the teaching cluster

All compute nodes on the teaching cluster are connected via a gigabit Ethernet network. MPI libraries currently installed on the teaching cluster are listed below.

OpenMPI

You can find all OpenMPI modules available on the teaching cluster by running the following command on a teaching cluster node:

module spider openmpi

These are some of the modules available:

  • OpenMPI 2.1.2, using GNU 6.4.0 compilers, available in module OpenMPI/2.1.2-GCC-6.4.0-2.28. To use it, load the module with
module load OpenMPI/2.1.2-GCC-6.4.0-2.28
  • OpenMPI 2.0.2, using GNU 6.3.0 compilers, available in module OpenMPI/2.0.2-GCC-6.3.0-2.27. To use it, load the module with
module load OpenMPI/2.0.2-GCC-6.3.0-2.27
  • OpenMPI 1.10.3, using GNU 5.4.0 compilers, available in module OpenMPI/1.10.3-GCC-5.4.0-2.26. To use it, load the module with
module load OpenMPI/1.10.3-GCC-5.4.0-2.26